Pour vos statistiques, dans Excel la fonction NB.SI va vous permettre de compter un nombre de cellules en fonction d’un critère particulier.
Vous pourrez ainsi compter automatiquement le nombre de cellule :

  • dont le nom commence par une lettre
  • correspondant à un nom particulier
  • dont la valeur est supérieur ou inférieur à une valeur

Cette fonction de comptage conditionnel utilise la syntaxe suivante :

NB.SI(plage, critères)

Les deux arguments (plage et critères) sont obligatoires.
Plage : Représente l’étendu des cellules à prendre en compte. Les valeurs vident ou textuelles seront ignorées.
Critères : Correspond à vos critères de recherche.
Les critères ne prennent pas en compte la casse du texte (Les deux chaines Carine et CARINE seront identiques pour la fonction).
Le critère peut correspondre à du texte, un nombre, une formule mathématique ou à un numéro de cellules.
Pour écrire vos critères de recherche, vous pouvez utiliser les caractères suivants :

  • ? Le point d’interrogation correspond a n’importe quel caractère.
  • * L’asterix remplace n’importe quelle chaine de caractères
  • & Va vous permettre de concaténer des informations dans votre requête.

Exemple d’utilisation de la fonction de comptage NB.SI:

(proposition de différents formules pour dénombrer une quantité de cellules)

Premier Classe Vainqueur drapeau

Félicitation, vous êtes le 1er.


Pour un relevé de notes d’une classe, soit le tableau de notes suivant :

  • Achille : 10
  • Leelou : 15
  • Alice : 12
  • Pierre : 2
  • Manon : 15

Et la mise en place des paramètres suivants :

  • Note Minimale : 12
  • Recherche de note : <=10

Exemple de relevé de notes Excel et d utilisation de la fonction NB.SI

Exemple de relevé de notes Excel pour l’utilisation de la fonction NB.SI


Les différents totaux suivants seront calculés grâce aux formules données dans la troisième colonne du tableau :

Énoncé Total Formule
Recherche du nombre d’enfant dont le prénom commence par « A »2=NB.SI(A2:A6;"a*")
Recherche du nombre d’enfant s’appelant Manon1=NB.SI(A2:A6;"Manon")
Recherche du nombre d’élève ayant plus de 103=NB.SI(B2:B6;">10")
Recherche du nombre d’enfant ayant moins que la valeur de la cellule F32=NB.SI(B2:B6;"<"&F3)
Recherche du nombre d’élève ayant une note correspondant à la formule de la cellule F42=NB.SI(B2:B6;F4)

Pour aller plus loin vous serez peut être intéressé par les articles suivants :

Mots clefs liés à cet article:

  • vainqueur
  • nombre de cellules dont la valeur est dans une plage de critères
  • image de vainqueur
  • excel recherche nombre criteres correspondants
  • excel formule nombre si mois
  • excel dénombrer le nombre de cellules contentant une valeur supérieur à zéro
  • excel creer unrelevé de notes
  • excel comptabiliser un critere
  • excel comptabiliser si mois et autre critère
  • fonction specifique excel